linux 安装完 jdk1.5 ,出现 java.lang.NoClassDefFoundError: com/sun/tools/javac/Main

安装完jdk后,java -version 能现实版本,但是运行java程序就出现问题,例如 javac a.java 的时候,出现

Exception in thread "main" java.lang.NoClassDefFoundError: com/sun/tools/javac/Main

原因是jdk目录下面的lib包中的tools.pack 没有转换成tools.jar

转换方法:

http://www.laoz.net/?p=175

版权所有,作者:老钟,如若转载,请注明出处:https://www.laoz.net/180.html

赞 (1)
老钟
上一篇 2011 年 11 月 25 日 上午 12:56
下一篇 2011 年 12 月 02 日 下午 12:36

相关推荐

  • Linux下搭建php运行环境【转】

    需要安装的软件: 1. 安装mysql 1.1安装编译器gcc 最小化安装,没有安装编译器 yum install gcc yum install gcc-c++ 如果不安装,在编译mysql的时候会出现【exec: g++: not found】错误 1.2安装ncurses-5.6.tar…

    vps教程 2011 年 08 月 16 日
  • Linux初级使用,切换字符界面、配置网络

    在linux中是叫文本界面而不是字符界面。方法如下: vi /etc/inittab id:3:initdefault: (大约在18行左右,其中3代表启动级别) 5代表的是图形界面 以后在你重启系统的时候都会进入字符界面。 ----------------------…

    vps教程 2011 年 10 月 16 日
  • Linux下解压RAR软件下载和解压.zip和.rar文件

    下载地址:http://www.rarsoft.com/download.htm(目前最新为RAR 3.71 for Linux) 以最新的为准。 对于Window下的常见压缩文件.zip和.rar,Linux也有相应的方法来解压它们: 1:对于.zip linux下提供了zip和unzip程…

    vps教程 2011 年 09 月 06 日
  • 新购买的VPS,为保证后期安全需要进行的设置

    1、修改root的登陆密码,添加一个新用户登陆管理SSH #passwd 命令可以修改用户密码 用adduser命令添加一个普通用户,命令如下: #adduser tom  //添加一个名为tom的用户 #passwd tom   //修改密码 2、设置权限,禁…

    vps教程 2016 年 07 月 01 日
  • lnmp安装阿里云免费SSL,出现welcome to nginx页面,提示403错误解决办法

    lnmp安装阿里云免费SSL 申请的时候要注意如下: 保护一个明细域名,例如: buy.example.com,或next.buy.example.com, 各个明细子域名都算一个域名 本机环境使用lnmp服务,需要修改nginx的内容 阿里云官方提供的设置办…

    vps教程 2017 年 09 月 28 日
  • 目前我在工作中常用的linux命令

    top   看cpu  内存  程序是否运行 c   显示命令路径 ctrl + c    终止 q   终止 空格  自动刷新 pwd    当前所在目录 ll   查看所有文件   (文件权限  所有者) ll * | grep  aa    查看aa文件 ls    查看所有文件…

    vps教程 2011 年 08 月 17 日
  • lnmp 运行一段时间后出现nginx 502 Bad Gateway的解决方法

    导致这个问题的原因很多解决:设置一下参数,重启php服务设置参数可以参考:http://www.henry24264.com/?p=1040/home/lnmp/ restart如果重启出现这个问题:Stoping LNMP... Nginx program is&n…

    vps教程 2012 年 11 月 02 日
  • lnmp1.7升级php提升失败的解决办法

    ERROR: cannot verify www.php.net's certificate, issued by ‘/C=US/O=Let’s Encrypt/CN=R3’:use `--no-check-certif` 解决方法是安装一个ca-certificates包 sudo yum install -y ca-certificates 然后再次升级即…

    vps教程 2023 年 08 月 11 日
  • thinkphp5.0写的项目放到lnmp上出现404错误

    thinphp5.0在Nginx上不适用pathinfo格式的url,在项目的Nginx配置文件里找到include enable-php.conf 改为 include enable-php-pathinfo.conf ,然后就可以了 第一步:打开nginx配置文件 /usr/local/nginx/conf/nignx…

    vps教程 2023 年 11 月 28 日
  • CentOS7 网站开启ssl证书后,网站无法访问,提示ERR_CONNECTION_REFUSED

    CentOS7服务器,安装lnmp, 原本网站正常运行,添加SSL证书后,发现网站拒绝访问,提示: 无法显示此网页 网站暂时无法连接,错误代码 ERR_CONNECTION_REFUSED 解决方法如下: 1, 检查系统防火墙firewall是否添加了…

    vps教程 2021 年 02 月 26 日