Almalinux服务器如何安装Fail2ban

ae0cfbe6ceacb415a69be00d32f1a7ea

Fail2ban是一款安全保护工具,触发限制后会创建防火墙规则封锁IP,诸如对ssh暴力破解、ftp/http密码穷举等场景提供强有力的保护,主要作用概要为以下几点:

  • 避免被穷举攻击(brute force)
  • 查看验证失败的日志
  • 自动创建防火墙规则封锁IP
  • 支持多种服务
  • 高度可定制

1. 启用EPEL仓库

sudo dnf install epel-release

2. 安装fail2ban

使用dnf命令来安装fail2ban

sudo dnf install fail2ban

3. 修改关键文件,配置文件路径默在/etc/fail2ban,只需要配置jail.local

[DEFAULT]

#此参数为加白的网段、IP,可以是域名、网段或单个IP,空格隔开。

ignoreip = 127.0.0.1/8 ::1

#设置被封锁的时间间隔,如下表示10分钟,可以是秒(s)、分钟(m)、小时(h)、天(d),不带单位则默认为s,-1表示永久封锁。

bantime = 10m

#检测的间隔时间,在间隔时间内,当>=maxtretry设置的失败次数,则触发限制,禁止访问。

findtime = 10m

#findtime时间内的最大失败次数

maxretry = 5

 

[sshd]

enabled = true

port = 22 #ssh端口

logpath = /var/log/auth.log #日志路径

backend = %(sshd_backend)s #后台管理程序,默认由systemd接管,无需修改

此时要注意了,上面的修改是注释掉前面的#号,不是添加,若添加会有重复,fail2ban会启动失败

4. 重启fail2ban

systemctl restart fail2ban #重启服务

5. 检验fail2ban是否启动了

fail2ban-client status

fail2ban-client status sshd

 

版权所有,作者:老钟,如若转载,请注明出处:https://www.laoz.net/56315.html

(0)
老钟
上一篇 2025 年 12 月 11 日 下午 5:35
下一篇 2026 年 05 月 24 日 下午 10:53

相关推荐

  • couldn't flush system prefs

    运行程序时,发现报此错误:警告: Couldn't flush system prefs: java.util.prefs.BackingStoreException: java.io.FileNotFoundException: /etc/.java/.systemPrefs/prefs…

    vps教程 2012 年 08 月 13 日
  • 2016-9-22 搬瓦工最新优惠信息,最新优惠码

    Bandwagonhost又称为搬瓦工,现在已经被屏蔽了,尽量翻{哈哈}墙访问 老钟用了一段时间,搬瓦工的主机比较稳定,访问速度还算可以 如果搭配国内的CDN使用,访问速度能减少到300毫秒以下,这个速度算是不错了 现在凤…

    2016 年 09 月 22 日
  • Linux下解压RAR软件下载和解压.zip和.rar文件

    下载地址:http://www.rarsoft.com/download.htm(目前最新为RAR 3.71 for Linux) 以最新的为准。 对于Window下的常见压缩文件.zip和.rar,Linux也有相应的方法来解压它们: 1:对于.zip linux下提供了zip和unzip程…

    vps教程 2011 年 09 月 06 日
  • linux 查找目录下的所有文件中是否含有某个字符串

    查找目录下的所有文件中是否含有某个字符串  find .|xargs grep -ri "IBM"  查找目录下的所有文件中是否含有某个字符串,并且只打印出文件名  find .|xargs grep -ri "IBM" -l  1.正则表达式    (1)正则表达式一般…

    vps教程 2014 年 07 月 01 日
  • Rockylinux8/Almalinux8 安装lnmp一键安装包

    由于centos停更,很多云服务器服务商不支持centos7或者centos8,所以打算装个Rockylinux或者Almalinux玩玩。 当然,为了省事方便,选用军哥的lnmp一键安装包; 安装的时候发现因为openssl的版本,导致了lnmp安装失…

    2025 年 12 月 11 日
  • 2016-9-28 搬瓦工套餐继续更新,原来11.99刀的已经卖完

    搬瓦工vps,这个是继之前84vps,老钟极力给大家推荐的一个性价比高的vps 上次给大家推荐的一个11.99刀,机房在凤凰城,国内访问的速度一般般,但是配置不错,可惜已经卖光了 今天,发现LA的机房又推出几款套餐,最…

    2016 年 09 月 28 日
  • Linux初级使用,切换字符界面、配置网络

    在linux中是叫文本界面而不是字符界面。方法如下: vi /etc/inittab id:3:initdefault: (大约在18行左右,其中3代表启动级别) 5代表的是图形界面 以后在你重启系统的时候都会进入字符界面。 ----------------------…

    vps教程 2011 年 10 月 16 日
  • linux - java启动脚本

    懒,时间长了不经常写,会忘记记录下来JAVA_HOME=/usr/java/jdk1.6.0_14   CLASSPATH=.:$JAVA_HOME/lib/dt.jar:$JAVA_HOME/lib/tools.jar:./lib/mysql-connector-java-5.1.17-bin.jar   PATH=.:$JAVA_HOM…

    vps教程 2012 年 11 月 29 日
  • CentOS7 网站开启ssl证书后,网站无法访问,提示ERR_CONNECTION_REFUSED

    CentOS7服务器,安装lnmp, 原本网站正常运行,添加SSL证书后,发现网站拒绝访问,提示: 无法显示此网页 网站暂时无法连接,错误代码 ERR_CONNECTION_REFUSED 解决方法如下: 1, 检查系统防火墙firewall是否添加了…

    vps教程 2021 年 02 月 26 日
  • linux 安装完 jdk1.5 ,出现 java.lang.NoClassDefFoundError: com/sun/tools/javac/Main

    安装完jdk后,java -version 能现实版本,但是运行java程序就出现问题,例如 javac a.java 的时候,出现 Exception in thread "main" java.lang.NoClassDefFoundError: com/sun/tools/javac/Main 原因是jdk目录下面…

    vps教程 2011 年 11 月 25 日