linux安装jdk出现java/lang/NoClassDefFoundError: java/lang/Object错误的解决方案

出现这个问题,是通过这篇文章解决的:

http://www.cnblogs.com/chenguangyu/archive/2009/11/06/1597706.html

记得rt.pack 和 tools.pack 这两个都要处理好,都要 转换成  .jar  的形式

rt.pack 是在jre/lib 下面的   tools.pack  是在lib 下面的 (均针对jdk的目录)

=========================================================

近日在redhat上安装jdk出现了一个莫名的错误

Error occurred during initialization of VM
java/lang/NoClassDefFoundError: java/lang/Object

辛苦google了一个小时,终于找到了解决方案

首先要确认的是环境变量的设置是否正确

相信大家都是很细心的,这方面如果有错误也会很容易发现

然而还有一个隐蔽的地方也会产生上述的错误

就是lib和jre/lib文件夹中的rt和tools是否是打包后的形式

如果发现rt.pack 和 tools.pack 那么多半问题就出在这里

解决方法也很简单,只要将相应文件解压成rt.jar 和 tools.jar

可以使用bin里面的unpack200工具

如:unpack200 rt.pack rt.jar

解压后java -version应该就没有问题了~~

版权所有,作者:老钟,如若转载,请注明出处:https://www.laoz.net/175.html

(2)
老钟
上一篇 2011 年 11 月 25 日 上午 12:55
下一篇 2011 年 11 月 25 日 上午 1:25

相关推荐

  • thinkphp5.0写的项目放到lnmp上出现404错误

    thinphp5.0在Nginx上不适用pathinfo格式的url,在项目的Nginx配置文件里找到include enable-php.conf 改为 include enable-php-pathinfo.conf ,然后就可以了 第一步:打开nginx配置文件 /usr/local/nginx/conf/nignx…

    vps教程 2023 年 11 月 28 日
  • 关于Almalinux9使用的一些心得

    鉴于Centos后期不维护的缘故,把一些系统改为Almalinux9,这个属于Centos8的一个社区升级版,很多命令是跟Centos8相似的; 下面讲一下在设置中出现的一个命令错误提示: 使用yum查找提供此功能的的软件包:yum provi…

    vps教程 2023 年 04 月 13 日
  • 解决Lnmp(Nginx)下wordpress二级目录伪静态出现404的问题

    问题:主站是采用wordpress架构的网站,想要在其二级目录再多做一个子站,发现在相同伪静态下面,二级目录的伪静态失败,出现404错误 那么解决wordpress二级目录伪静态出现404的问题,仅仅需要进行如下设置即可,非…

    vps教程 2016 年 11 月 11 日
  • centOS6安装lnmp1.7提示memcached not found错误的解决

    不管怎么测试,centos6安装lnmp1.7总是会提示memcached报错,建议有报错的兄弟更换到lnmp16,这样省事! 报错信息如下: configure.ac:3: error: Autoconf version 2.68 or higher is required 这个意思是需要安装A…

    vps教程 2020 年 08 月 29 日
  • 在Linux中配置网络

    与网络有关的常用命令: --------------------------------------------------------------------------------------------------------- 1、ifconfig # ifconfig [接口名称] 查看某个设备的配置: # ifconfig eth0…

    vps教程 2011 年 10 月 30 日
  • Linux中 常用命令 和 进程管理

    Vim: 文本编辑器 vim   文件名 vim  + n(行号)  如  vim  + 3  /etc/passwd 光标在第三行; + /word       光标在有word的行首; Vim主要有三种模式: 命令,输入,末行这三种模式 命令模式 —>  输入模式 1)i…

    vps教程 2011 年 08 月 11 日
  • 新购买的VPS,为保证后期安全需要进行的设置

    1、修改root的登陆密码,添加一个新用户登陆管理SSH #passwd 命令可以修改用户密码 用adduser命令添加一个普通用户,命令如下: #adduser tom  //添加一个名为tom的用户 #passwd tom   //修改密码 2、设置权限,禁…

    vps教程 2016 年 07 月 01 日
  • CentOS7以上系统修改SSH端口号的方法

    CentOS目前发展到8了,以前一直使用CentOS6,是因为从centOS7开始,操作的命令就已经有很大的变化,一直以来都懒得换系统,但是按照目前发展的趋势,必须得迈出这一步了。 需要使用新版的系统,那么首先第一步肯定…

    vps教程 2020 年 08 月 22 日
  • Linux下解压RAR软件下载和解压.zip和.rar文件

    下载地址:http://www.rarsoft.com/download.htm(目前最新为RAR 3.71 for Linux) 以最新的为准。 对于Window下的常见压缩文件.zip和.rar,Linux也有相应的方法来解压它们: 1:对于.zip linux下提供了zip和unzip程…

    vps教程 2011 年 09 月 06 日
  • linux - java启动脚本

    懒,时间长了不经常写,会忘记记录下来JAVA_HOME=/usr/java/jdk1.6.0_14   CLASSPATH=.:$JAVA_HOME/lib/dt.jar:$JAVA_HOME/lib/tools.jar:./lib/mysql-connector-java-5.1.17-bin.jar   PATH=.:$JAVA_HOM…

    vps教程 2012 年 11 月 29 日

评论列表(1条)

  • Blondie 2011 年 12 月 07 日 下午 3:23

    That saves me. Thanks for being so sesnible!