linux安装jdk出现java/lang/NoClassDefFoundError: java/lang/Object错误的解决方案

出现这个问题,是通过这篇文章解决的:

http://www.cnblogs.com/chenguangyu/archive/2009/11/06/1597706.html

记得rt.pack 和 tools.pack 这两个都要处理好,都要 转换成  .jar  的形式

rt.pack 是在jre/lib 下面的   tools.pack  是在lib 下面的 (均针对jdk的目录)

=========================================================

近日在redhat上安装jdk出现了一个莫名的错误

Error occurred during initialization of VM
java/lang/NoClassDefFoundError: java/lang/Object

辛苦google了一个小时,终于找到了解决方案

首先要确认的是环境变量的设置是否正确

相信大家都是很细心的,这方面如果有错误也会很容易发现

然而还有一个隐蔽的地方也会产生上述的错误

就是lib和jre/lib文件夹中的rt和tools是否是打包后的形式

如果发现rt.pack 和 tools.pack 那么多半问题就出在这里

解决方法也很简单,只要将相应文件解压成rt.jar 和 tools.jar

可以使用bin里面的unpack200工具

如:unpack200 rt.pack rt.jar

解压后java -version应该就没有问题了~~

版权所有,作者:老钟,如若转载,请注明出处:https://www.laoz.net/175.html

(2)
老钟
上一篇 2011 年 11 月 25 日 上午 12:55
下一篇 2011 年 11 月 25 日 上午 1:25

相关推荐

  • 新建VPS服务器的安全防护设置

    0x00 起因 最近我自己的 vps 越来越不稳定,开始还以为是因为我自己在路由器里面添加了透明代理使用的流量大造成的,后来越来越发觉不正常,毕竟我也是用了几年 vps 的老手了,总觉的不正常。后来 iftop 发现我的 v…

    vps教程 2020 年 05 月 04 日
  • Nginx服务器安装SSL后全站http跳转https

     网上很多教程关于如何做全站的http转https,我这里只讲述nginx服务器的跳转方法之前提到过阿里云申请的SSL如何部署到服务器:lnmp安装阿里云免费SSL,出现welcome to nginx页面,提示403错误解决办法这里主要讲述…

    vps教程 2018 年 04 月 13 日
  • 一级域名绑定二级目录伪静态 和 二级目录wordpress伪静态规则写法

    这LNMP下,原wordpress伪静态的写法: location / { if (-f $request_filename/index.html){ rewrite (.*) $1/index.html break; } if (-f $request_filename/index.php){ rewrite (.*) $1/index.php; } if (!-f $r…

    vps教程 2013 年 05 月 03 日
  • Almalinux服务器如何安装Fail2ban

    Fail2ban是一款安全保护工具,触发限制后会创建防火墙规则封锁IP,诸如对ssh暴力破解、ftp/http密码穷举等场景提供强有力的保护,主要作用概要为以下几点: 避免被穷举攻击(brute force) 查看验证失败的日志 自动创…

    2025 年 12 月 12 日
  • Linux VPS被暴力攻击,破解ROOT登陆密码,linux安全防范DenyHosts

    前两天登陆后台,查看了一下管理日志,发现vps被别人连接ssh端口,被连续登录SSH字典猜root密码,具体可以使用命令: tail -f /var/log/auth.log 可以查看到,想暴力破解的IP地址,大部分为浙江和江苏的IP,不知道…

    vps教程 2014 年 07 月 29 日
  • BURST倒闭了,把网站都迁移到Linode

      前几天收到邮件,burst说7月25停止所有服务,我还以为是我的服务器到期了,看了其他一些VPS大牛的文章,才知道原来burst倒闭了,其实VPS还是可以继续使用的,因为他的VPS卖给了hostwinds ,我的vps是7.25到…

    2014 年 06 月 28 日
  • linux - java启动脚本

    懒,时间长了不经常写,会忘记记录下来JAVA_HOME=/usr/java/jdk1.6.0_14   CLASSPATH=.:$JAVA_HOME/lib/dt.jar:$JAVA_HOME/lib/tools.jar:./lib/mysql-connector-java-5.1.17-bin.jar   PATH=.:$JAVA_HOM…

    vps教程 2012 年 11 月 29 日
  • linux下统计文件夹文件数量

    linux下统计文件夹数量 egrep "7966.org"  file|wc -l 最近bluehost主机上,发现文件限制为50,000个文件。于是想看一下,主机文件夹里的文件数量,由于主机是linux的,所以找了一下。大致有两种: 一种是: ls   -…

    vps教程 2011 年 11 月 23 日
  • lnmp 运行一段时间后出现nginx 502 Bad Gateway的解决方法

    导致这个问题的原因很多解决:设置一下参数,重启php服务设置参数可以参考:http://www.henry24264.com/?p=1040/home/lnmp/ restart如果重启出现这个问题:Stoping LNMP... Nginx program is&n…

    vps教程 2012 年 11 月 02 日
  • VMware Workstation安装centos 6.5,解决传输 vmdb 错误 message

    在win7 64位上面用虚拟机安装centos 6.5,主要是试用linux里面的一些功能来工作。 在设置完成后,启动虚拟机的时候,会出现传输 vmdb 错误 message错误,原因是你没有试用超级管理员运行 文章来源:http://www.data…

    2017 年 03 月 28 日

评论列表(1条)

  • Blondie 2011 年 12 月 07 日 下午 3:23

    That saves me. Thanks for being so sesnible!