lnmp 运行一段时间后出现nginx 502 Bad Gateway的解决方法

导致这个问题的原因很多

解决:设置一下参数,重启php服务

设置参数可以参考:

http://www.henry24264.com/?p=1040

/home/lnmp/ restart

如果重启出现这个问题:

Stoping LNMP...
Nginx program is stop
Shutting down php_fpm /usr/local/php/sbin/php-fpm: line 69: kill: (499) - No such process
................................... failed
PHP-FPM program is stop
Shutting down MySQL. SUCCESS!
MySQL program is stop
Starting LNMP...
Nginx start successfully!
php-fpm is runing!
Starting MySQL. SUCCESS!
MySQL start successfully!

则:/usr/local/php/sbin/php-fpm restart

再试过几次

版权所有,作者:老钟,如若转载,请注明出处:https://www.laoz.net/295.html

赞 (1)
老钟
上一篇 2012 年 10 月 22 日 上午 11:13
下一篇 2012 年 11 月 29 日 下午 6:56

相关推荐

  • 修改linux文件夹及其子文件夹、文件的权限

    入手了vps,需要很多linux的命令,遇到不懂的,网速搜一下,并且总结出来 有个文件夹, 里边有好多子文件夹和文件,chmod 777 foldername 得重复输入多次, 因为chmod一次只能赋给当前文件夹权限,不能传递到子文件…

    vps教程 2011 年 07 月 31 日
  • 2016-9-28 搬瓦工套餐继续更新,原来11.99刀的已经卖完

    搬瓦工vps,这个是继之前84vps,老钟极力给大家推荐的一个性价比高的vps 上次给大家推荐的一个11.99刀,机房在凤凰城,国内访问的速度一般般,但是配置不错,可惜已经卖光了 今天,发现LA的机房又推出几款套餐,最…

    2016 年 09 月 28 日
  • linux下统计文件夹文件数量

    linux下统计文件夹数量 egrep "7966.org"  file|wc -l 最近bluehost主机上,发现文件限制为50,000个文件。于是想看一下,主机文件夹里的文件数量,由于主机是linux的,所以找了一下。大致有两种: 一种是: ls   -…

    vps教程 2011 年 11 月 23 日
  • 解决Lnmp(Nginx)下wordpress二级目录伪静态出现404的问题

    问题:主站是采用wordpress架构的网站,想要在其二级目录再多做一个子站,发现在相同伪静态下面,二级目录的伪静态失败,出现404错误 那么解决wordpress二级目录伪静态出现404的问题,仅仅需要进行如下设置即可,非…

    vps教程 2016 年 11 月 11 日
  • Linux 删除单个或多个文件

    Linux操作 Linux常用命令   rm :linux下的删除指令 rm  filename 删除名为filename 的文件 rm -rf /var/log/httpd/access 将会删除/var/log/httpd/access目录以及其下所有文件、文件夹

    vps教程 2011 年 07 月 31 日
  • lnmp1.7升级php提升失败的解决办法

    ERROR: cannot verify www.php.net's certificate, issued by ‘/C=US/O=Let’s Encrypt/CN=R3’:use `--no-check-certif` 解决方法是安装一个ca-certificates包 sudo yum install -y ca-certificates 然后再次升级即…

    vps教程 2023 年 08 月 11 日
  • 管理VPS ,常用的Linux命令

    系统 # uname -a # 查看内核/操作系统/CPU信息 # head -n 1 /etc/issue # 查看操作系统版本 # cat /proc/cpuinfo # 查看CPU信息 # hostname # 查看计算机名 # lspci -tv # 列出所有PCI设备 # lsusb -tv # 列出所有U…

    vps教程 2011 年 09 月 19 日
  • VMware Workstation安装centos 6.5,解决传输 vmdb 错误 message

    在win7 64位上面用虚拟机安装centos 6.5,主要是试用linux里面的一些功能来工作。 在设置完成后,启动虚拟机的时候,会出现传输 vmdb 错误 message错误,原因是你没有试用超级管理员运行 文章来源:http://www.data…

    2017 年 03 月 28 日
  • Rockylinux8/Almalinux8 安装lnmp一键安装包

    由于centos停更,很多云服务器服务商不支持centos7或者centos8,所以打算装个Rockylinux或者Almalinux玩玩。 当然,为了省事方便,选用军哥的lnmp一键安装包; 安装的时候发现因为openssl的版本,导致了lnmp安装失…

    2025 年 12 月 11 日
  • 解决lnmp 1.2,lnmp 1.3无法远程连接数据库

    安装了lnmp 1.2之后的版本,发现远程连接mysql总是失败,原本以为是设置的问题,后来才发现原来是lnmp中iptables的规则问题 首先先要确定自己的设置是没有问题的,访问数据库的用户使用的是%权限 如果设置没问题,…

    vps教程 2016 年 08 月 18 日