lnmp 运行一段时间后出现nginx 502 Bad Gateway的解决方法

导致这个问题的原因很多

解决:设置一下参数,重启php服务

设置参数可以参考:

http://www.henry24264.com/?p=1040

/home/lnmp/ restart

如果重启出现这个问题:

Stoping LNMP...
Nginx program is stop
Shutting down php_fpm /usr/local/php/sbin/php-fpm: line 69: kill: (499) - No such process
................................... failed
PHP-FPM program is stop
Shutting down MySQL. SUCCESS!
MySQL program is stop
Starting LNMP...
Nginx start successfully!
php-fpm is runing!
Starting MySQL. SUCCESS!
MySQL start successfully!

则:/usr/local/php/sbin/php-fpm restart

再试过几次

版权所有,作者:老钟,如若转载,请注明出处:https://www.laoz.net/295.html

赞 (1)
老钟
上一篇 2012 年 10 月 22 日 上午 11:13
下一篇 2012 年 11 月 29 日 下午 6:56

相关推荐

  • CentOS7以上系统修改SSH端口号的方法

    CentOS目前发展到8了,以前一直使用CentOS6,是因为从centOS7开始,操作的命令就已经有很大的变化,一直以来都懒得换系统,但是按照目前发展的趋势,必须得迈出这一步了。 需要使用新版的系统,那么首先第一步肯定…

    vps教程 2020 年 08 月 22 日
  • 关于Almalinux9使用的一些心得

    鉴于Centos后期不维护的缘故,把一些系统改为Almalinux9,这个属于Centos8的一个社区升级版,很多命令是跟Centos8相似的; 下面讲一下在设置中出现的一个命令错误提示: 使用yum查找提供此功能的的软件包:yum provi…

    vps教程 2023 年 04 月 13 日
  • lnmp1.7升级php提升失败的解决办法

    ERROR: cannot verify www.php.net's certificate, issued by ‘/C=US/O=Let’s Encrypt/CN=R3’:use `--no-check-certif` 解决方法是安装一个ca-certificates包 sudo yum install -y ca-certificates 然后再次升级即…

    vps教程 2023 年 08 月 11 日
  • Nginx服务器安装SSL后全站http跳转https

     网上很多教程关于如何做全站的http转https,我这里只讲述nginx服务器的跳转方法之前提到过阿里云申请的SSL如何部署到服务器:lnmp安装阿里云免费SSL,出现welcome to nginx页面,提示403错误解决办法这里主要讲述…

    vps教程 2018 年 04 月 13 日
  • VPS安全设置 增强VPS安全性防止被攻破

    安全是一个VPS最基本的必备条件,若您的VPS三天两头被人攻破,那么对于网站来说也没什么意义了,所以,在创建了Web服务器之后,您首先要做的事情就是将您的VPS加固,至少让普通黑客没有办法能够攻破您的网站。 用户…

    vps教程 2018 年 01 月 17 日
  • centos7 vps服务器的安全设置

    大家都知道centOS7以上的跟centOS6在命令是有很大变化的,未来也是趋势 老钟博客之前服务器安全的分析均是在CentOS6基础上进行,因为习惯了,一般不喜欢去更换系统 但是CentOS7以上基础安全性和运行效果是更加好 那…

    vps教程 2020 年 07 月 03 日
  • Linux初级使用,切换字符界面、配置网络

    在linux中是叫文本界面而不是字符界面。方法如下: vi /etc/inittab id:3:initdefault: (大约在18行左右,其中3代表启动级别) 5代表的是图形界面 以后在你重启系统的时候都会进入字符界面。 ----------------------…

    vps教程 2011 年 10 月 16 日
  • 本地CentOS6.5安装配置JDK1.6

    Linux系统安装jdk 首先,在网上下载jdk, 例如下载了 jdk-6u38-linux-i586.bin 可以是在linux系统下载,也可以在你自己的电脑下载,再通过ftp上传到linux,放在/usr/local下 下面安装jdk 添加执行权限 [root@linux ~…

    vps教程 2017 年 06 月 20 日
  • 新建VPS服务器的安全防护设置

    0x00 起因 最近我自己的 vps 越来越不稳定,开始还以为是因为我自己在路由器里面添加了透明代理使用的流量大造成的,后来越来越发觉不正常,毕竟我也是用了几年 vps 的老手了,总觉的不正常。后来 iftop 发现我的 v…

    vps教程 2020 年 05 月 04 日
  • thinkphp5.0写的项目放到lnmp上出现404错误

    thinphp5.0在Nginx上不适用pathinfo格式的url,在项目的Nginx配置文件里找到include enable-php.conf 改为 include enable-php-pathinfo.conf ,然后就可以了 第一步:打开nginx配置文件 /usr/local/nginx/conf/nignx…

    vps教程 2023 年 11 月 28 日