linux安装jdk出现java/lang/NoClassDefFoundError: java/lang/Object错误的解决方案

出现这个问题,是通过这篇文章解决的:

http://www.cnblogs.com/chenguangyu/archive/2009/11/06/1597706.html

记得rt.pack 和 tools.pack 这两个都要处理好,都要 转换成  .jar  的形式

rt.pack 是在jre/lib 下面的   tools.pack  是在lib 下面的 (均针对jdk的目录)

=========================================================

近日在redhat上安装jdk出现了一个莫名的错误

Error occurred during initialization of VM
java/lang/NoClassDefFoundError: java/lang/Object

辛苦google了一个小时,终于找到了解决方案

首先要确认的是环境变量的设置是否正确

相信大家都是很细心的,这方面如果有错误也会很容易发现

然而还有一个隐蔽的地方也会产生上述的错误

就是lib和jre/lib文件夹中的rt和tools是否是打包后的形式

如果发现rt.pack 和 tools.pack 那么多半问题就出在这里

解决方法也很简单,只要将相应文件解压成rt.jar 和 tools.jar

可以使用bin里面的unpack200工具

如:unpack200 rt.pack rt.jar

解压后java -version应该就没有问题了~~

版权所有,作者:老钟,如若转载,请注明出处:https://www.laoz.net/175.html

赞 (2)
老钟
上一篇 2011 年 11 月 25 日 上午 12:55
下一篇 2011 年 11 月 25 日 上午 1:25

相关推荐

  • thinkphp5.0写的项目放到lnmp上出现404错误

    thinphp5.0在Nginx上不适用pathinfo格式的url,在项目的Nginx配置文件里找到include enable-php.conf 改为 include enable-php-pathinfo.conf ,然后就可以了 第一步:打开nginx配置文件 /usr/local/nginx/conf/nignx…

    vps教程 2023 年 11 月 28 日
  • 一级域名绑定二级目录伪静态 和 二级目录wordpress伪静态规则写法

    这LNMP下,原wordpress伪静态的写法: location / { if (-f $request_filename/index.html){ rewrite (.*) $1/index.html break; } if (-f $request_filename/index.php){ rewrite (.*) $1/index.php; } if (!-f $r…

    vps教程 2013 年 05 月 03 日
  • 新购买的VPS,为保证后期安全需要进行的设置

    1、修改root的登陆密码,添加一个新用户登陆管理SSH #passwd 命令可以修改用户密码 用adduser命令添加一个普通用户,命令如下: #adduser tom  //添加一个名为tom的用户 #passwd tom   //修改密码 2、设置权限,禁…

    vps教程 2016 年 07 月 01 日
  • lnmp 运行一段时间后出现nginx 502 Bad Gateway的解决方法

    导致这个问题的原因很多解决:设置一下参数,重启php服务设置参数可以参考:http://www.henry24264.com/?p=1040/home/lnmp/ restart如果重启出现这个问题:Stoping LNMP... Nginx program is&n…

    vps教程 2012 年 11 月 02 日
  • linux命令scp远程拷贝

    1、scp复制到远程 scp local_file remote_username@remote_ip:remote_folder 实例: scp test.txt root@remote_ip:/home/root/ 第1,2个指定了用户名,命令执行后需要再输入密码,第1个仅指定了远程的目录,文件名字…

    vps教程 2020 年 11 月 21 日
  • Linux下搭建php运行环境【转】

    需要安装的软件: 1. 安装mysql 1.1安装编译器gcc 最小化安装,没有安装编译器 yum install gcc yum install gcc-c++ 如果不安装,在编译mysql的时候会出现【exec: g++: not found】错误 1.2安装ncurses-5.6.tar…

    vps教程 2011 年 08 月 16 日
  • 新建VPS服务器的安全防护设置

    0x00 起因 最近我自己的 vps 越来越不稳定,开始还以为是因为我自己在路由器里面添加了透明代理使用的流量大造成的,后来越来越发觉不正常,毕竟我也是用了几年 vps 的老手了,总觉的不正常。后来 iftop 发现我的 v…

    vps教程 2020 年 05 月 04 日
  • 关于Almalinux9使用的一些心得

    鉴于Centos后期不维护的缘故,把一些系统改为Almalinux9,这个属于Centos8的一个社区升级版,很多命令是跟Centos8相似的; 下面讲一下在设置中出现的一个命令错误提示: 使用yum查找提供此功能的的软件包:yum provi…

    vps教程 2023 年 04 月 13 日
  • centos7 vps服务器的安全设置

    大家都知道centOS7以上的跟centOS6在命令是有很大变化的,未来也是趋势 老钟博客之前服务器安全的分析均是在CentOS6基础上进行,因为习惯了,一般不喜欢去更换系统 但是CentOS7以上基础安全性和运行效果是更加好 那…

    vps教程 2020 年 07 月 03 日
  • 本地CentOS6.5安装配置JDK1.6

    Linux系统安装jdk 首先,在网上下载jdk, 例如下载了 jdk-6u38-linux-i586.bin 可以是在linux系统下载,也可以在你自己的电脑下载,再通过ftp上传到linux,放在/usr/local下 下面安装jdk 添加执行权限 [root@linux ~…

    vps教程 2017 年 06 月 20 日

评论列表(1条)

  • Blondie 2011 年 12 月 07 日 下午 3:23

    That saves me. Thanks for being so sesnible!