linux安装jdk出现java/lang/NoClassDefFoundError: java/lang/Object错误的解决方案

出现这个问题,是通过这篇文章解决的:

http://www.cnblogs.com/chenguangyu/archive/2009/11/06/1597706.html

记得rt.pack 和 tools.pack 这两个都要处理好,都要 转换成  .jar  的形式

rt.pack 是在jre/lib 下面的   tools.pack  是在lib 下面的 (均针对jdk的目录)

=========================================================

近日在redhat上安装jdk出现了一个莫名的错误

Error occurred during initialization of VM
java/lang/NoClassDefFoundError: java/lang/Object

辛苦google了一个小时,终于找到了解决方案

首先要确认的是环境变量的设置是否正确

相信大家都是很细心的,这方面如果有错误也会很容易发现

然而还有一个隐蔽的地方也会产生上述的错误

就是lib和jre/lib文件夹中的rt和tools是否是打包后的形式

如果发现rt.pack 和 tools.pack 那么多半问题就出在这里

解决方法也很简单,只要将相应文件解压成rt.jar 和 tools.jar

可以使用bin里面的unpack200工具

如:unpack200 rt.pack rt.jar

解压后java -version应该就没有问题了~~

版权所有,作者:老钟,如若转载,请注明出处:https://www.laoz.net/175.html

赞 (2)
老钟
上一篇 2011 年 11 月 25 日 上午 12:55
下一篇 2011 年 11 月 25 日 上午 1:25

相关推荐

  • Linux初级使用,切换字符界面、配置网络

    在linux中是叫文本界面而不是字符界面。方法如下: vi /etc/inittab id:3:initdefault: (大约在18行左右,其中3代表启动级别) 5代表的是图形界面 以后在你重启系统的时候都会进入字符界面。 ----------------------…

    vps教程 2011 年 10 月 16 日
  • thinkphp5.0写的项目放到lnmp上出现404错误

    thinphp5.0在Nginx上不适用pathinfo格式的url,在项目的Nginx配置文件里找到include enable-php.conf 改为 include enable-php-pathinfo.conf ,然后就可以了 第一步:打开nginx配置文件 /usr/local/nginx/conf/nignx…

    vps教程 2023 年 11 月 28 日
  • 一级域名绑定二级目录伪静态 和 二级目录wordpress伪静态规则写法

    这LNMP下,原wordpress伪静态的写法: location / { if (-f $request_filename/index.html){ rewrite (.*) $1/index.html break; } if (-f $request_filename/index.php){ rewrite (.*) $1/index.php; } if (!-f $r…

    vps教程 2013 年 05 月 03 日
  • Linux中 常用命令 和 进程管理

    Vim: 文本编辑器 vim   文件名 vim  + n(行号)  如  vim  + 3  /etc/passwd 光标在第三行; + /word       光标在有word的行首; Vim主要有三种模式: 命令,输入,末行这三种模式 命令模式 —>  输入模式 1)i…

    vps教程 2011 年 08 月 11 日
  • linux定时任务

    例子   每天早上6点 0 6 * * * echo "Good morning." >> /tmp/test.txt //注意单纯echo,从屏幕上看不到任何输出,因为cron把任何输出都email到root的信箱了。 每两个小时 0 */2 * * * echo "Have a bre…

    vps教程 2011 年 08 月 29 日
  • VMware Workstation安装centos 6.5,解决传输 vmdb 错误 message

    在win7 64位上面用虚拟机安装centos 6.5,主要是试用linux里面的一些功能来工作。 在设置完成后,启动虚拟机的时候,会出现传输 vmdb 错误 message错误,原因是你没有试用超级管理员运行 文章来源:http://www.data…

    2017 年 03 月 28 日
  • Linux 删除单个或多个文件

    Linux操作 Linux常用命令   rm :linux下的删除指令 rm  filename 删除名为filename 的文件 rm -rf /var/log/httpd/access 将会删除/var/log/httpd/access目录以及其下所有文件、文件夹

    vps教程 2011 年 07 月 31 日
  • Linux VPS被暴力攻击,破解ROOT登陆密码,linux安全防范DenyHosts

    前两天登陆后台,查看了一下管理日志,发现vps被别人连接ssh端口,被连续登录SSH字典猜root密码,具体可以使用命令: tail -f /var/log/auth.log 可以查看到,想暴力破解的IP地址,大部分为浙江和江苏的IP,不知道…

    vps教程 2014 年 07 月 29 日
  • 新建VPS服务器的安全防护设置

    0x00 起因 最近我自己的 vps 越来越不稳定,开始还以为是因为我自己在路由器里面添加了透明代理使用的流量大造成的,后来越来越发觉不正常,毕竟我也是用了几年 vps 的老手了,总觉的不正常。后来 iftop 发现我的 v…

    vps教程 2020 年 05 月 04 日
  • linux - java启动脚本

    懒,时间长了不经常写,会忘记记录下来JAVA_HOME=/usr/java/jdk1.6.0_14   CLASSPATH=.:$JAVA_HOME/lib/dt.jar:$JAVA_HOME/lib/tools.jar:./lib/mysql-connector-java-5.1.17-bin.jar   PATH=.:$JAVA_HOM…

    vps教程 2012 年 11 月 29 日

评论列表(1条)

  • Blondie 2011 年 12 月 07 日 下午 3:23

    That saves me. Thanks for being so sesnible!