linux安装jdk出现java/lang/NoClassDefFoundError: java/lang/Object错误的解决方案

出现这个问题,是通过这篇文章解决的:

http://www.cnblogs.com/chenguangyu/archive/2009/11/06/1597706.html

记得rt.pack 和 tools.pack 这两个都要处理好,都要 转换成  .jar  的形式

rt.pack 是在jre/lib 下面的   tools.pack  是在lib 下面的 (均针对jdk的目录)

=========================================================

近日在redhat上安装jdk出现了一个莫名的错误

Error occurred during initialization of VM
java/lang/NoClassDefFoundError: java/lang/Object

辛苦google了一个小时,终于找到了解决方案

首先要确认的是环境变量的设置是否正确

相信大家都是很细心的,这方面如果有错误也会很容易发现

然而还有一个隐蔽的地方也会产生上述的错误

就是lib和jre/lib文件夹中的rt和tools是否是打包后的形式

如果发现rt.pack 和 tools.pack 那么多半问题就出在这里

解决方法也很简单,只要将相应文件解压成rt.jar 和 tools.jar

可以使用bin里面的unpack200工具

如:unpack200 rt.pack rt.jar

解压后java -version应该就没有问题了~~

版权所有,作者:老钟,如若转载,请注明出处:https://www.laoz.net/175.html

赞 (2)
老钟
上一篇 2011 年 11 月 25 日 上午 12:55
下一篇 2011 年 11 月 25 日 上午 1:25

相关推荐

  • Linux下搭建php运行环境【转】

    需要安装的软件: 1. 安装mysql 1.1安装编译器gcc 最小化安装,没有安装编译器 yum install gcc yum install gcc-c++ 如果不安装,在编译mysql的时候会出现【exec: g++: not found】错误 1.2安装ncurses-5.6.tar…

    vps教程 2011 年 08 月 16 日
  • linux命令scp远程拷贝

    1、scp复制到远程 scp local_file remote_username@remote_ip:remote_folder 实例: scp test.txt root@remote_ip:/home/root/ 第1,2个指定了用户名,命令执行后需要再输入密码,第1个仅指定了远程的目录,文件名字…

    vps教程 2020 年 11 月 21 日
  • linux 安装完 jdk1.5 ,出现 java.lang.NoClassDefFoundError: com/sun/tools/javac/Main

    安装完jdk后,java -version 能现实版本,但是运行java程序就出现问题,例如 javac a.java 的时候,出现 Exception in thread "main" java.lang.NoClassDefFoundError: com/sun/tools/javac/Main 原因是jdk目录下面…

    vps教程 2011 年 11 月 25 日
  • 2016-9-28 搬瓦工套餐继续更新,原来11.99刀的已经卖完

    搬瓦工vps,这个是继之前84vps,老钟极力给大家推荐的一个性价比高的vps 上次给大家推荐的一个11.99刀,机房在凤凰城,国内访问的速度一般般,但是配置不错,可惜已经卖光了 今天,发现LA的机房又推出几款套餐,最…

    2016 年 09 月 28 日
  • CentOS7以上系统修改SSH端口号的方法

    CentOS目前发展到8了,以前一直使用CentOS6,是因为从centOS7开始,操作的命令就已经有很大的变化,一直以来都懒得换系统,但是按照目前发展的趋势,必须得迈出这一步了。 需要使用新版的系统,那么首先第一步肯定…

    vps教程 2020 年 08 月 22 日
  • 新购买的VPS,为保证后期安全需要进行的设置

    1、修改root的登陆密码,添加一个新用户登陆管理SSH #passwd 命令可以修改用户密码 用adduser命令添加一个普通用户,命令如下: #adduser tom  //添加一个名为tom的用户 #passwd tom   //修改密码 2、设置权限,禁…

    vps教程 2016 年 07 月 01 日
  • 解决lnmp 1.2,lnmp 1.3无法远程连接数据库

    安装了lnmp 1.2之后的版本,发现远程连接mysql总是失败,原本以为是设置的问题,后来才发现原来是lnmp中iptables的规则问题 首先先要确定自己的设置是没有问题的,访问数据库的用户使用的是%权限 如果设置没问题,…

    vps教程 2016 年 08 月 18 日
  • Linux中 常用命令 和 进程管理

    Vim: 文本编辑器 vim   文件名 vim  + n(行号)  如  vim  + 3  /etc/passwd 光标在第三行; + /word       光标在有word的行首; Vim主要有三种模式: 命令,输入,末行这三种模式 命令模式 —>  输入模式 1)i…

    vps教程 2011 年 08 月 11 日
  • CentOS7 网站开启ssl证书后,网站无法访问,提示ERR_CONNECTION_REFUSED

    CentOS7服务器,安装lnmp, 原本网站正常运行,添加SSL证书后,发现网站拒绝访问,提示: 无法显示此网页 网站暂时无法连接,错误代码 ERR_CONNECTION_REFUSED 解决方法如下: 1, 检查系统防火墙firewall是否添加了…

    vps教程 2021 年 02 月 26 日
  • 新建VPS服务器的安全防护设置

    0x00 起因 最近我自己的 vps 越来越不稳定,开始还以为是因为我自己在路由器里面添加了透明代理使用的流量大造成的,后来越来越发觉不正常,毕竟我也是用了几年 vps 的老手了,总觉的不正常。后来 iftop 发现我的 v…

    vps教程 2020 年 05 月 04 日

评论列表(1条)

  • Blondie 2011 年 12 月 07 日 下午 3:23

    That saves me. Thanks for being so sesnible!