lnmp 运行一段时间后出现nginx 502 Bad Gateway的解决方法

导致这个问题的原因很多

解决:设置一下参数,重启php服务

设置参数可以参考:

http://www.henry24264.com/?p=1040

/home/lnmp/ restart

如果重启出现这个问题:

Stoping LNMP...
Nginx program is stop
Shutting down php_fpm /usr/local/php/sbin/php-fpm: line 69: kill: (499) - No such process
................................... failed
PHP-FPM program is stop
Shutting down MySQL. SUCCESS!
MySQL program is stop
Starting LNMP...
Nginx start successfully!
php-fpm is runing!
Starting MySQL. SUCCESS!
MySQL start successfully!

则:/usr/local/php/sbin/php-fpm restart

再试过几次

版权所有,作者:老钟,如若转载,请注明出处:https://www.laoz.net/295.html

(1)
老钟
上一篇 2012 年 10 月 22 日 上午 11:13
下一篇 2012 年 11 月 29 日 下午 6:56

相关推荐

  • 新建VPS服务器的安全防护设置

    0x00 起因 最近我自己的 vps 越来越不稳定,开始还以为是因为我自己在路由器里面添加了透明代理使用的流量大造成的,后来越来越发觉不正常,毕竟我也是用了几年 vps 的老手了,总觉的不正常。后来 iftop 发现我的 v…

    vps教程 2020 年 05 月 04 日
  • linux安装jdk出现java/lang/NoClassDefFoundError: java/lang/Object错误的解决方案

    出现这个问题,是通过这篇文章解决的: http://www.cnblogs.com/chenguangyu/archive/2009/11/06/1597706.html 记得rt.pack 和 tools.pack 这两个都要处理好,都要 转换成  .jar  的形式 rt.pack 是在jre/lib 下面…

    vps教程 2011 年 11 月 25 日
  • Linux 删除单个或多个文件

    Linux操作 Linux常用命令   rm :linux下的删除指令 rm  filename 删除名为filename 的文件 rm -rf /var/log/httpd/access 将会删除/var/log/httpd/access目录以及其下所有文件、文件夹

    vps教程 2011 年 07 月 31 日
  • 2016-9-28 搬瓦工套餐继续更新,原来11.99刀的已经卖完

    搬瓦工vps,这个是继之前84vps,老钟极力给大家推荐的一个性价比高的vps 上次给大家推荐的一个11.99刀,机房在凤凰城,国内访问的速度一般般,但是配置不错,可惜已经卖光了 今天,发现LA的机房又推出几款套餐,最…

    2016 年 09 月 28 日
  • VMware Workstation安装centos 6.5,解决传输 vmdb 错误 message

    在win7 64位上面用虚拟机安装centos 6.5,主要是试用linux里面的一些功能来工作。 在设置完成后,启动虚拟机的时候,会出现传输 vmdb 错误 message错误,原因是你没有试用超级管理员运行 文章来源:http://www.data…

    2017 年 03 月 28 日
  • linux下解压zip文件

    安装zip: apt-get install zip unzip命令     语法:unzip [选项] 压缩文件名.zip     各选项的含义分别为:     -x 文件列表 解压缩文件,但不包括指定的file文件。     -v 查看压…

    vps教程 2011 年 08 月 02 日
  • linux 查找目录下的所有文件中是否含有某个字符串

    查找目录下的所有文件中是否含有某个字符串  find .|xargs grep -ri "IBM"  查找目录下的所有文件中是否含有某个字符串,并且只打印出文件名  find .|xargs grep -ri "IBM" -l  1.正则表达式    (1)正则表达式一般…

    vps教程 2014 年 07 月 01 日
  • linux 安装完 jdk1.5 ,出现 java.lang.NoClassDefFoundError: com/sun/tools/javac/Main

    安装完jdk后,java -version 能现实版本,但是运行java程序就出现问题,例如 javac a.java 的时候,出现 Exception in thread "main" java.lang.NoClassDefFoundError: com/sun/tools/javac/Main 原因是jdk目录下面…

    vps教程 2011 年 11 月 25 日
  • 解决lnmp 1.2,lnmp 1.3无法远程连接数据库

    安装了lnmp 1.2之后的版本,发现远程连接mysql总是失败,原本以为是设置的问题,后来才发现原来是lnmp中iptables的规则问题 首先先要确定自己的设置是没有问题的,访问数据库的用户使用的是%权限 如果设置没问题,…

    vps教程 2016 年 08 月 18 日
  • Linux中 常用命令 和 进程管理

    Vim: 文本编辑器 vim   文件名 vim  + n(行号)  如  vim  + 3  /etc/passwd 光标在第三行; + /word       光标在有word的行首; Vim主要有三种模式: 命令,输入,末行这三种模式 命令模式 —>  输入模式 1)i…

    vps教程 2011 年 08 月 11 日