lnmp 运行一段时间后出现nginx 502 Bad Gateway的解决方法

导致这个问题的原因很多

解决:设置一下参数,重启php服务

设置参数可以参考:

http://www.henry24264.com/?p=1040

/home/lnmp/ restart

如果重启出现这个问题:

Stoping LNMP...
Nginx program is stop
Shutting down php_fpm /usr/local/php/sbin/php-fpm: line 69: kill: (499) - No such process
................................... failed
PHP-FPM program is stop
Shutting down MySQL. SUCCESS!
MySQL program is stop
Starting LNMP...
Nginx start successfully!
php-fpm is runing!
Starting MySQL. SUCCESS!
MySQL start successfully!

则:/usr/local/php/sbin/php-fpm restart

再试过几次

版权所有,作者:老钟,如若转载,请注明出处:https://www.laoz.net/295.html

赞 (1)
老钟
上一篇 2012 年 10 月 22 日 上午 11:13
下一篇 2012 年 11 月 29 日 下午 6:56

相关推荐

  • Linux下搭建php运行环境【转】

    需要安装的软件: 1. 安装mysql 1.1安装编译器gcc 最小化安装,没有安装编译器 yum install gcc yum install gcc-c++ 如果不安装,在编译mysql的时候会出现【exec: g++: not found】错误 1.2安装ncurses-5.6.tar…

    vps教程 2011 年 08 月 16 日
  • CentOS7以上系统修改SSH端口号的方法

    CentOS目前发展到8了,以前一直使用CentOS6,是因为从centOS7开始,操作的命令就已经有很大的变化,一直以来都懒得换系统,但是按照目前发展的趋势,必须得迈出这一步了。 需要使用新版的系统,那么首先第一步肯定…

    vps教程 2020 年 08 月 22 日
  • linux - java启动脚本

    懒,时间长了不经常写,会忘记记录下来JAVA_HOME=/usr/java/jdk1.6.0_14   CLASSPATH=.:$JAVA_HOME/lib/dt.jar:$JAVA_HOME/lib/tools.jar:./lib/mysql-connector-java-5.1.17-bin.jar   PATH=.:$JAVA_HOM…

    vps教程 2012 年 11 月 29 日
  • 硬盘安装redhat 6.5图文教程 linux rhel-server-6.5安装

    硬盘安装redhat    硬盘安装linux redhat有很多版本,我安装在一台台式电脑上面,这台电脑原来在使用的,内存4G,可以全盘格式化再安装,不过我装了双系统,即win7和linux 首先第一步,下载redhat 6.5的ISO镜像,我…

    2016 年 08 月 16 日
  • lnmp安装阿里云免费SSL,出现welcome to nginx页面,提示403错误解决办法

    lnmp安装阿里云免费SSL 申请的时候要注意如下: 保护一个明细域名,例如: buy.example.com,或next.buy.example.com, 各个明细子域名都算一个域名 本机环境使用lnmp服务,需要修改nginx的内容 阿里云官方提供的设置办…

    vps教程 2017 年 09 月 28 日
  • 2016-9-22 搬瓦工最新优惠信息,最新优惠码

    Bandwagonhost又称为搬瓦工,现在已经被屏蔽了,尽量翻{哈哈}墙访问 老钟用了一段时间,搬瓦工的主机比较稳定,访问速度还算可以 如果搭配国内的CDN使用,访问速度能减少到300毫秒以下,这个速度算是不错了 现在凤…

    2016 年 09 月 22 日
  • centOS6安装lnmp1.7提示memcached not found错误的解决

    不管怎么测试,centos6安装lnmp1.7总是会提示memcached报错,建议有报错的兄弟更换到lnmp16,这样省事! 报错信息如下: configure.ac:3: error: Autoconf version 2.68 or higher is required 这个意思是需要安装A…

    vps教程 2020 年 08 月 29 日
  • Linux 删除单个或多个文件

    Linux操作 Linux常用命令   rm :linux下的删除指令 rm  filename 删除名为filename 的文件 rm -rf /var/log/httpd/access 将会删除/var/log/httpd/access目录以及其下所有文件、文件夹

    vps教程 2011 年 07 月 31 日
  • 管理VPS ,常用的Linux命令

    系统 # uname -a # 查看内核/操作系统/CPU信息 # head -n 1 /etc/issue # 查看操作系统版本 # cat /proc/cpuinfo # 查看CPU信息 # hostname # 查看计算机名 # lspci -tv # 列出所有PCI设备 # lsusb -tv # 列出所有U…

    vps教程 2011 年 09 月 19 日
  • Linux VPS被暴力攻击,破解ROOT登陆密码,linux安全防范DenyHosts

    前两天登陆后台,查看了一下管理日志,发现vps被别人连接ssh端口,被连续登录SSH字典猜root密码,具体可以使用命令: tail -f /var/log/auth.log 可以查看到,想暴力破解的IP地址,大部分为浙江和江苏的IP,不知道…

    vps教程 2014 年 07 月 29 日