lnmp 运行一段时间后出现nginx 502 Bad Gateway的解决方法

导致这个问题的原因很多

解决:设置一下参数,重启php服务

设置参数可以参考:

http://www.henry24264.com/?p=1040

/home/lnmp/ restart

如果重启出现这个问题:

Stoping LNMP...
Nginx program is stop
Shutting down php_fpm /usr/local/php/sbin/php-fpm: line 69: kill: (499) - No such process
................................... failed
PHP-FPM program is stop
Shutting down MySQL. SUCCESS!
MySQL program is stop
Starting LNMP...
Nginx start successfully!
php-fpm is runing!
Starting MySQL. SUCCESS!
MySQL start successfully!

则:/usr/local/php/sbin/php-fpm restart

再试过几次

版权所有,作者:老钟,如若转载,请注明出处:https://www.laoz.net/295.html

赞 (1)
老钟
上一篇 2012 年 10 月 22 日 上午 11:13
下一篇 2012 年 11 月 29 日 下午 6:56

相关推荐

  • 关于Almalinux9使用的一些心得

    鉴于Centos后期不维护的缘故,把一些系统改为Almalinux9,这个属于Centos8的一个社区升级版,很多命令是跟Centos8相似的; 下面讲一下在设置中出现的一个命令错误提示: 使用yum查找提供此功能的的软件包:yum provi…

    vps教程 2023 年 04 月 13 日
  • centos7 vps服务器的安全设置

    大家都知道centOS7以上的跟centOS6在命令是有很大变化的,未来也是趋势 老钟博客之前服务器安全的分析均是在CentOS6基础上进行,因为习惯了,一般不喜欢去更换系统 但是CentOS7以上基础安全性和运行效果是更加好 那…

    vps教程 2020 年 07 月 03 日
  • VMware Workstation安装centos 6.5,解决传输 vmdb 错误 message

    在win7 64位上面用虚拟机安装centos 6.5,主要是试用linux里面的一些功能来工作。 在设置完成后,启动虚拟机的时候,会出现传输 vmdb 错误 message错误,原因是你没有试用超级管理员运行 文章来源:http://www.data…

    2017 年 03 月 28 日
  • Linux中 常用命令 和 进程管理

    Vim: 文本编辑器 vim   文件名 vim  + n(行号)  如  vim  + 3  /etc/passwd 光标在第三行; + /word       光标在有word的行首; Vim主要有三种模式: 命令,输入,末行这三种模式 命令模式 —>  输入模式 1)i…

    vps教程 2011 年 08 月 11 日
  • 解决Lnmp(Nginx)下wordpress二级目录伪静态出现404的问题

    问题:主站是采用wordpress架构的网站,想要在其二级目录再多做一个子站,发现在相同伪静态下面,二级目录的伪静态失败,出现404错误 那么解决wordpress二级目录伪静态出现404的问题,仅仅需要进行如下设置即可,非…

    vps教程 2016 年 11 月 11 日
  • 管理VPS ,常用的Linux命令

    系统 # uname -a # 查看内核/操作系统/CPU信息 # head -n 1 /etc/issue # 查看操作系统版本 # cat /proc/cpuinfo # 查看CPU信息 # hostname # 查看计算机名 # lspci -tv # 列出所有PCI设备 # lsusb -tv # 列出所有U…

    vps教程 2011 年 09 月 19 日
  • linux安装jdk出现java/lang/NoClassDefFoundError: java/lang/Object错误的解决方案

    出现这个问题,是通过这篇文章解决的: http://www.cnblogs.com/chenguangyu/archive/2009/11/06/1597706.html 记得rt.pack 和 tools.pack 这两个都要处理好,都要 转换成  .jar  的形式 rt.pack 是在jre/lib 下面…

    vps教程 2011 年 11 月 25 日
  • CentOS7以上系统修改SSH端口号的方法

    CentOS目前发展到8了,以前一直使用CentOS6,是因为从centOS7开始,操作的命令就已经有很大的变化,一直以来都懒得换系统,但是按照目前发展的趋势,必须得迈出这一步了。 需要使用新版的系统,那么首先第一步肯定…

    vps教程 2020 年 08 月 22 日
  • 2016-9-28 搬瓦工套餐继续更新,原来11.99刀的已经卖完

    搬瓦工vps,这个是继之前84vps,老钟极力给大家推荐的一个性价比高的vps 上次给大家推荐的一个11.99刀,机房在凤凰城,国内访问的速度一般般,但是配置不错,可惜已经卖光了 今天,发现LA的机房又推出几款套餐,最…

    2016 年 09 月 28 日
  • centOS6安装lnmp1.7提示memcached not found错误的解决

    不管怎么测试,centos6安装lnmp1.7总是会提示memcached报错,建议有报错的兄弟更换到lnmp16,这样省事! 报错信息如下: configure.ac:3: error: Autoconf version 2.68 or higher is required 这个意思是需要安装A…

    vps教程 2020 年 08 月 29 日