lnmp 运行一段时间后出现nginx 502 Bad Gateway的解决方法

导致这个问题的原因很多

解决:设置一下参数,重启php服务

设置参数可以参考:

http://www.henry24264.com/?p=1040

/home/lnmp/ restart

如果重启出现这个问题:

Stoping LNMP...
Nginx program is stop
Shutting down php_fpm /usr/local/php/sbin/php-fpm: line 69: kill: (499) - No such process
................................... failed
PHP-FPM program is stop
Shutting down MySQL. SUCCESS!
MySQL program is stop
Starting LNMP...
Nginx start successfully!
php-fpm is runing!
Starting MySQL. SUCCESS!
MySQL start successfully!

则:/usr/local/php/sbin/php-fpm restart

再试过几次

版权所有,作者:老钟,如若转载,请注明出处:https://www.laoz.net/295.html

赞 (1)
老钟
上一篇 2012 年 10 月 22 日 上午 11:13
下一篇 2012 年 11 月 29 日 下午 6:56

相关推荐

  • vmware下centos找不到网卡eth0 没有ip

    vmware安装完成centos之后,使用ifconfig命令,发现没有eth0出现 那么,可以用ifconfig -a 试试,如果还是没看到,则使用命令ifconfig eth0 up开启网卡 如果发现显示出来的信息没有显示ip地址,这个时候vi /etc/sys…

    vps教程 2017 年 03 月 28 日
  • linux 安装完 jdk1.5 ,出现 java.lang.NoClassDefFoundError: com/sun/tools/javac/Main

    安装完jdk后,java -version 能现实版本,但是运行java程序就出现问题,例如 javac a.java 的时候,出现 Exception in thread "main" java.lang.NoClassDefFoundError: com/sun/tools/javac/Main 原因是jdk目录下面…

    vps教程 2011 年 11 月 25 日
  • 2016-9-22 搬瓦工最新优惠信息,最新优惠码

    Bandwagonhost又称为搬瓦工,现在已经被屏蔽了,尽量翻{哈哈}墙访问 老钟用了一段时间,搬瓦工的主机比较稳定,访问速度还算可以 如果搭配国内的CDN使用,访问速度能减少到300毫秒以下,这个速度算是不错了 现在凤…

    2016 年 09 月 22 日
  • 目前我在工作中常用的linux命令

    top   看cpu  内存  程序是否运行 c   显示命令路径 ctrl + c    终止 q   终止 空格  自动刷新 pwd    当前所在目录 ll   查看所有文件   (文件权限  所有者) ll * | grep  aa    查看aa文件 ls    查看所有文件…

    vps教程 2011 年 08 月 17 日
  • Linux VPS被暴力攻击,破解ROOT登陆密码,linux安全防范DenyHosts

    前两天登陆后台,查看了一下管理日志,发现vps被别人连接ssh端口,被连续登录SSH字典猜root密码,具体可以使用命令: tail -f /var/log/auth.log 可以查看到,想暴力破解的IP地址,大部分为浙江和江苏的IP,不知道…

    vps教程 2014 年 07 月 29 日
  • Linux下解压RAR软件下载和解压.zip和.rar文件

    下载地址:http://www.rarsoft.com/download.htm(目前最新为RAR 3.71 for Linux) 以最新的为准。 对于Window下的常见压缩文件.zip和.rar,Linux也有相应的方法来解压它们: 1:对于.zip linux下提供了zip和unzip程…

    vps教程 2011 年 09 月 06 日
  • 2016-9-28 搬瓦工套餐继续更新,原来11.99刀的已经卖完

    搬瓦工vps,这个是继之前84vps,老钟极力给大家推荐的一个性价比高的vps 上次给大家推荐的一个11.99刀,机房在凤凰城,国内访问的速度一般般,但是配置不错,可惜已经卖光了 今天,发现LA的机房又推出几款套餐,最…

    2016 年 09 月 28 日
  • Linux 删除单个或多个文件

    Linux操作 Linux常用命令   rm :linux下的删除指令 rm  filename 删除名为filename 的文件 rm -rf /var/log/httpd/access 将会删除/var/log/httpd/access目录以及其下所有文件、文件夹

    vps教程 2011 年 07 月 31 日
  • Nginx服务器安装SSL后全站http跳转https

     网上很多教程关于如何做全站的http转https,我这里只讲述nginx服务器的跳转方法之前提到过阿里云申请的SSL如何部署到服务器:lnmp安装阿里云免费SSL,出现welcome to nginx页面,提示403错误解决办法这里主要讲述…

    vps教程 2018 年 04 月 13 日
  • 新建VPS服务器的安全防护设置

    0x00 起因 最近我自己的 vps 越来越不稳定,开始还以为是因为我自己在路由器里面添加了透明代理使用的流量大造成的,后来越来越发觉不正常,毕竟我也是用了几年 vps 的老手了,总觉的不正常。后来 iftop 发现我的 v…

    vps教程 2020 年 05 月 04 日