lnmp 运行一段时间后出现nginx 502 Bad Gateway的解决方法

导致这个问题的原因很多

解决:设置一下参数,重启php服务

设置参数可以参考:

http://www.henry24264.com/?p=1040

/home/lnmp/ restart

如果重启出现这个问题:

Stoping LNMP...
Nginx program is stop
Shutting down php_fpm /usr/local/php/sbin/php-fpm: line 69: kill: (499) - No such process
................................... failed
PHP-FPM program is stop
Shutting down MySQL. SUCCESS!
MySQL program is stop
Starting LNMP...
Nginx start successfully!
php-fpm is runing!
Starting MySQL. SUCCESS!
MySQL start successfully!

则:/usr/local/php/sbin/php-fpm restart

再试过几次

版权所有,作者:老钟,如若转载,请注明出处:https://www.laoz.net/295.html

赞 (1)
老钟
上一篇 2012 年 10 月 22 日 上午 11:13
下一篇 2012 年 11 月 29 日 下午 6:56

相关推荐

  • 管理VPS ,常用的Linux命令

    系统 # uname -a # 查看内核/操作系统/CPU信息 # head -n 1 /etc/issue # 查看操作系统版本 # cat /proc/cpuinfo # 查看CPU信息 # hostname # 查看计算机名 # lspci -tv # 列出所有PCI设备 # lsusb -tv # 列出所有U…

    vps教程 2011 年 09 月 19 日
  • lnmp安装阿里云免费SSL,出现welcome to nginx页面,提示403错误解决办法

    lnmp安装阿里云免费SSL 申请的时候要注意如下: 保护一个明细域名,例如: buy.example.com,或next.buy.example.com, 各个明细子域名都算一个域名 本机环境使用lnmp服务,需要修改nginx的内容 阿里云官方提供的设置办…

    vps教程 2017 年 09 月 28 日
  • 解决VMware安装Centos在安装VMware Tools就停止的情况

    在Vmware上面安装Centos 6.5来测试,发现总是在安装VMware Tools停止安装了,当然,也在网上找了很多解决办法,下面可以提供给大家参考 我的解决:在刚开始创建虚拟机的时候,不需要添加iso文件进行安装,这样就可…

    2017 年 06 月 20 日
  • CentOS7修改SSH端口

    一、修改ssh配置文件sshd_config [root@bogon ~]# vi /etc/ssh/sshd_config 二、防火墙放行 [root@bogon ~]# firewall-cmd --zone=public --add-port=22345/tcp --permanent [root@bogon ~]# firewall-cmd --reload…

    2020 年 05 月 16 日
  • VPS安全设置 增强VPS安全性防止被攻破

    安全是一个VPS最基本的必备条件,若您的VPS三天两头被人攻破,那么对于网站来说也没什么意义了,所以,在创建了Web服务器之后,您首先要做的事情就是将您的VPS加固,至少让普通黑客没有办法能够攻破您的网站。 用户…

    vps教程 2018 年 01 月 17 日
  • VMware Workstation安装centos 6.5,解决传输 vmdb 错误 message

    在win7 64位上面用虚拟机安装centos 6.5,主要是试用linux里面的一些功能来工作。 在设置完成后,启动虚拟机的时候,会出现传输 vmdb 错误 message错误,原因是你没有试用超级管理员运行 文章来源:http://www.data…

    2017 年 03 月 28 日
  • Linux中 常用命令 和 进程管理

    Vim: 文本编辑器 vim   文件名 vim  + n(行号)  如  vim  + 3  /etc/passwd 光标在第三行; + /word       光标在有word的行首; Vim主要有三种模式: 命令,输入,末行这三种模式 命令模式 —>  输入模式 1)i…

    vps教程 2011 年 08 月 11 日
  • 解决lnmp 1.2,lnmp 1.3无法远程连接数据库

    安装了lnmp 1.2之后的版本,发现远程连接mysql总是失败,原本以为是设置的问题,后来才发现原来是lnmp中iptables的规则问题 首先先要确定自己的设置是没有问题的,访问数据库的用户使用的是%权限 如果设置没问题,…

    vps教程 2016 年 08 月 18 日
  • 2016-9-28 搬瓦工套餐继续更新,原来11.99刀的已经卖完

    搬瓦工vps,这个是继之前84vps,老钟极力给大家推荐的一个性价比高的vps 上次给大家推荐的一个11.99刀,机房在凤凰城,国内访问的速度一般般,但是配置不错,可惜已经卖光了 今天,发现LA的机房又推出几款套餐,最…

    2016 年 09 月 28 日
  • 目前我在工作中常用的linux命令

    top   看cpu  内存  程序是否运行 c   显示命令路径 ctrl + c    终止 q   终止 空格  自动刷新 pwd    当前所在目录 ll   查看所有文件   (文件权限  所有者) ll * | grep  aa    查看aa文件 ls    查看所有文件…

    vps教程 2011 年 08 月 17 日