lnmp 运行一段时间后出现nginx 502 Bad Gateway的解决方法

导致这个问题的原因很多

解决:设置一下参数,重启php服务

设置参数可以参考:

http://www.henry24264.com/?p=1040

/home/lnmp/ restart

如果重启出现这个问题:

Stoping LNMP...
Nginx program is stop
Shutting down php_fpm /usr/local/php/sbin/php-fpm: line 69: kill: (499) - No such process
................................... failed
PHP-FPM program is stop
Shutting down MySQL. SUCCESS!
MySQL program is stop
Starting LNMP...
Nginx start successfully!
php-fpm is runing!
Starting MySQL. SUCCESS!
MySQL start successfully!

则:/usr/local/php/sbin/php-fpm restart

再试过几次

版权所有,作者:老钟,如若转载,请注明出处:https://www.laoz.net/295.html

赞 (1)
老钟
上一篇 2012 年 10 月 22 日 上午 11:13
下一篇 2012 年 11 月 29 日 下午 6:56

相关推荐

  • lnmp1.7升级php提升失败的解决办法

    ERROR: cannot verify www.php.net's certificate, issued by ‘/C=US/O=Let’s Encrypt/CN=R3’:use `--no-check-certif` 解决方法是安装一个ca-certificates包 sudo yum install -y ca-certificates 然后再次升级即…

    vps教程 2023 年 08 月 11 日
  • Almalinux服务器如何安装Fail2ban

    Fail2ban是一款安全保护工具,触发限制后会创建防火墙规则封锁IP,诸如对ssh暴力破解、ftp/http密码穷举等场景提供强有力的保护,主要作用概要为以下几点: 避免被穷举攻击(brute force) 查看验证失败的日志 自动创…

    2025 年 12 月 12 日
  • 解决Lnmp(Nginx)下wordpress二级目录伪静态出现404的问题

    问题:主站是采用wordpress架构的网站,想要在其二级目录再多做一个子站,发现在相同伪静态下面,二级目录的伪静态失败,出现404错误 那么解决wordpress二级目录伪静态出现404的问题,仅仅需要进行如下设置即可,非…

    vps教程 2016 年 11 月 11 日
  • CentOS7 网站开启ssl证书后,网站无法访问,提示ERR_CONNECTION_REFUSED

    CentOS7服务器,安装lnmp, 原本网站正常运行,添加SSL证书后,发现网站拒绝访问,提示: 无法显示此网页 网站暂时无法连接,错误代码 ERR_CONNECTION_REFUSED 解决方法如下: 1, 检查系统防火墙firewall是否添加了…

    vps教程 2021 年 02 月 26 日
  • Linux下搭建php运行环境【转】

    需要安装的软件: 1. 安装mysql 1.1安装编译器gcc 最小化安装,没有安装编译器 yum install gcc yum install gcc-c++ 如果不安装,在编译mysql的时候会出现【exec: g++: not found】错误 1.2安装ncurses-5.6.tar…

    vps教程 2011 年 08 月 16 日
  • Linux下解压RAR软件下载和解压.zip和.rar文件

    下载地址:http://www.rarsoft.com/download.htm(目前最新为RAR 3.71 for Linux) 以最新的为准。 对于Window下的常见压缩文件.zip和.rar,Linux也有相应的方法来解压它们: 1:对于.zip linux下提供了zip和unzip程…

    vps教程 2011 年 09 月 06 日
  • couldn't flush system prefs

    运行程序时,发现报此错误:警告: Couldn't flush system prefs: java.util.prefs.BackingStoreException: java.io.FileNotFoundException: /etc/.java/.systemPrefs/prefs…

    vps教程 2012 年 08 月 13 日
  • linux下统计文件夹文件数量

    linux下统计文件夹数量 egrep "7966.org"  file|wc -l 最近bluehost主机上,发现文件限制为50,000个文件。于是想看一下,主机文件夹里的文件数量,由于主机是linux的,所以找了一下。大致有两种: 一种是: ls   -…

    vps教程 2011 年 11 月 23 日
  • centOS6安装lnmp1.7提示memcached not found错误的解决

    不管怎么测试,centos6安装lnmp1.7总是会提示memcached报错,建议有报错的兄弟更换到lnmp16,这样省事! 报错信息如下: configure.ac:3: error: Autoconf version 2.68 or higher is required 这个意思是需要安装A…

    vps教程 2020 年 08 月 29 日
  • 新建VPS服务器的安全防护设置

    0x00 起因 最近我自己的 vps 越来越不稳定,开始还以为是因为我自己在路由器里面添加了透明代理使用的流量大造成的,后来越来越发觉不正常,毕竟我也是用了几年 vps 的老手了,总觉的不正常。后来 iftop 发现我的 v…

    vps教程 2020 年 05 月 04 日